Under maintenance

System Maintenance

Resolved
Major outage
Started over 1 year ago Lasted 1 day

Affected

Darkcleaver
Darkshade
Emberhand
Fistsworn
Goldbrow
Rockvisage
Updates
  • Resolved
    Resolved

    All Websites and Services are back online at this time.

  • Investigating
    Investigating

    Services are currently unavailable as we deal with some server maintenance and updates.